Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Blogs > luke_vtr_gy

Rate this Entry

saxo syndrome

Submit "saxo syndrome" to Google Submit "saxo syndrome" to Facebook Submit "saxo syndrome" to StumbleUpon Submit "saxo syndrome" to Digg Submit "saxo syndrome" to Twitter
Posted 4th July 2011 at 17:45 by luke_vtr_gy

herd it before , poor idle , engine management light on :panic:

well this one isnt a idle control valve lol

it all started on a rainy day , the dreaded engine
management light came on and it went into limp mode.

so i pulled over and could hear the coil pack shorting.

i was still down my street so parked it back up and let her dry out.

started her up next day and she had a lumpy idol and kept cutting out. so i cleaned all the connections with wd40 then fitted a new coil pack.. job done i fort ...

it made no difference ,, then it stopped working all together. i got somone to look into the matter. he told me the ecu was knackard.

so i tuck it out to send it for testing. un plugged it / removed it from the car. ooooo noooo water was dripping out .. so i opened it up,,, and its had quite abit of water in the case. :bash:

sooo i deiced that my ECU would be brown bread and ordered a re con,,

next day delivery, next day a box came to the door ,, whooop whoooop

plugged it in ,, and guess what it started first time,,

but thats not end of the story , it was miss fring so i fitted a new crank sensor ,,, that fixed that problem ,,, but,,,, now she is running very rich , so i changed the fuel pump no change, left battery off over night, pressed re set , checked all fuses , cleaned all the sensors , cleaned throttle body nothing ,, so i got the ecu scanned and the faults are ;

P0551 Power Steering Pressure Sensor Circuit Range/Performance
P0170 Fuel Trim Malfunction (Bank 1)
P0123 Throttle Position Sensor/Switch A Circuit High Input
P0327 Knock Sensor 1 Circuit Low Input (Bank I or Single Sensor)
P1327 Ignition - Integrated Phase detection

iv had a compression test done all good

i think the ecu needs setting up for my car ,,, but iv got somone to have a look at her tomorrow ,, il keep you posted

if anyone has any ideas ,, let me know
Posted in Uncategorized
Views 4163 Comments 1
Total Comments 1

Comments

  1. Old Comment
    i fixed this by putting the original ecu back in, after getting it repaired of course.
    Posted 12th August 2011 at 04:13 by luke_vtr_gy luke_vtr_gy is offline
 

All times are GMT. The time now is 03:34.