Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Blogs > Simo' Says...

I intend to use my blog to keep you informed of things happening with my car(s) and anything in life I find interesting, unusual or worthy of sharing! Please check back regularly to see what's been happening in the world of Simo
Rate this Entry

Playing with a 'PC' Polisher

Submit "Playing with a 'PC' Polisher" to Google Submit "Playing with a 'PC' Polisher" to Facebook Submit "Playing with a 'PC' Polisher" to StumbleUpon Submit "Playing with a 'PC' Polisher" to Digg Submit "Playing with a 'PC' Polisher" to Twitter
Posted 12th March 2010 at 19:41 by Simo

July 2007... Tarting up the bodywork!

Throughout 2006, intensive cleaning and 'detailing' of Saxo's became very popular within the Saxperience community - this was mainly due to the excellent advice and customer service offered by 'Polished Bliss'. I decided to casually jump in on this band wagon - I don't particularly have much spare time, but I like to pretend

All of the cool kids were importing Porter Cable 7424 orbital polishers, then buying 110v transformers to run these units, as no decent, reasonably priced orbital polishers were available from the UK.

My bodywork had not had a lot of attention for quite some time, and having had a couple of re-sprays over the years, there was plenty of little defects to try to correct. I grabbed some cutting paste and a range of waxes and sealants and began the long task of preparing and polishing each of the panels on the car.

It's fair to say, I never completed the whole car 'properly', but I did manage to learn what I was trying to achieve and made some pretty good progress on the main panels! Overall, the PC7424 is a nifty piece of kit. I just need to get more spare time to make proper use of it.

Views 8439 Comments 4
Total Comments 4

Comments

  1. Old Comment
    Predator_R32's Avatar
    looks good simon

    thats the proper pc, 7424 is oldskool
    Posted 13th March 2010 at 18:16 by Predator_R32 Predator_R32 is offline
  2. Old Comment
    hi this is stevensaxo
    i have a 1600 vtr saxo but i have a problem with it
    when i drive my car it radomly cuts out on me/dies
    and it takes about 25 - 30 mins to start up but the thing is it turns but it just wont start do you no wot it could be
    thank you....?
    Posted 11th April 2010 at 10:16 by stevensaxo stevensaxo is offline
  3. Old Comment

    ...

    i no it sound stupid lol :/
    bt it could jst need a gd service , when was the last time u did this ?
    Posted 30th March 2011 at 17:27 by scrans_sax scrans_sax is offline
  4. Old Comment
    engine temp sensor caused me that problem!
    Posted 6th February 2013 at 10:02 by r830ghu r830ghu is offline
 
Total Trackbacks 0

Trackbacks


All times are GMT. The time now is 05:30.