Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 14th September 2018, 20:02   #1
Crocko2p
Newbie
 
Join Date: Sep 2018
Posts: 7
Default Ticking noise from VTS engine

Any ideas what could cause an engine ticking noise?
Doesn't seem to be affected by engine speed - so is it unlikely to be tappets ? Oil levels are fine as is power...
Doesn't happen all the time, and doesn't seem to relate to engine being hot or cold.

Been trying to upload a video as I appreciate it's a pretty vague question without hearing it, but keep getting video failure with a message about missing security token
Crocko2 is offline   Reply With Quote
The Following User Says Thank You to Crocko2 For This Useful Post:
Old 15th September 2018, 11:20   #2
MartinObviously
Saxperience Forum Bum
Track / Motorsport PrepScotland Region Member
 
MartinObviously's Avatar
 
Join Date: Dec 2012
Location: Perth
Posts: 3,136
Car(s): Peugeot 106 1.5D Peugeot 106 GTI '78 XJ-S
Default

Maybe worn engine mount or something loose under the bonnet?
__________________
The rain kept a trollin'
MartinObviously is offline   Reply With Quote
Old 15th September 2018, 13:27   #3
stevo67
Saxperience Hardcore!
 
stevo67's Avatar
 
Join Date: Dec 2007
Location: smurfland.
Posts: 17,256
Car(s): Ex saxo owner.
Default

Loose heatshield?
stevo67 is offline   Reply With Quote
Old 15th September 2018, 14:19   #4
Crocko2p
Newbie
 
Join Date: Sep 2018
Posts: 7
Default

Thanks for the replies. If I can figure out how to upload a video, it might help...

Stevo67 Are you thinking the heat shield over the manifold? If so, I might remove this as it's not a daily drive and I plan on uprating the full exhaust system anyway.

I noticed the ECU isn't bolted down properly, but it sounds more like it's an engine now as opposed to a rattle.
Crocko2 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:27.