Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 3rd February 2020, 16:33   #1
Jonathancilia
Regular Poster
 
Jonathancilia's Avatar
 
Join Date: Sep 2017
Location: Malta
Posts: 317
Car(s): Lada samara 1.3 Citroen saxo 1.5d
Default Saxo door central locks

Hi, my saxo is driving me crazy, i installed a central locking kit like a year ago and since then rear door locks only lock and unlock randomly, sometimes they lock and only unlock half way and vice versa. I replaced the oem central lock because it had these same problems before. Front door actuators work fine. Where are the rear door actuators supposed to mount?<br><br>Sent from my SM-J710F using Tapatalk<br><br>
Jonathancilia is offline   Reply With Quote
Old 4th February 2020, 17:39   #2
stevo67
Saxperience Hardcore!
 
stevo67's Avatar
 
Join Date: Dec 2007
Location: smurfland.
Posts: 17,342
Car(s): Ex saxo owner.
Default

Are you sure the door cards are mounted correctly & not catching on anything?
stevo67 is offline   Reply With Quote
Old 4th February 2020, 17:52   #3
Jonathancilia
Regular Poster
 
Jonathancilia's Avatar
 
Join Date: Sep 2017
Location: Malta
Posts: 317
Car(s): Lada samara 1.3 Citroen saxo 1.5d
Default

Yes they are good. The problem is i couldnt set up the actuator where the door will close and open. It will either close and not open or vice versa no matter how i adjust. I dont see any mountings where they are supposed to mount. The factory one was installed on metal strips with holes. And so they are now<br><br>Sent from my SM-J710F using Tapatalk<br><br>
Jonathancilia is offline   Reply With Quote
Old 4th February 2020, 17:53   #4
Jonathancilia
Regular Poster
 
Jonathancilia's Avatar
 
Join Date: Sep 2017
Location: Malta
Posts: 317
Car(s): Lada samara 1.3 Citroen saxo 1.5d
Default

I installed this kit about a year ago from hawk.<br><br>Sent from my SM-J710F using Tapatalk<br><br>
Jonathancilia is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 18:54.