Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Engine/Performance

Saxo Engine/Performance If you're interested in tuning Saxo engines, or if you need to know something which is engine related... this is the place for you.

Reply
 
Thread Tools Display Modes
Old 20th July 2010, 14:41   #1
SxO13
Regular Poster
South East Region Member
 
Join Date: Jan 2010
Location: west sussex
Posts: 338
Car(s): Nissan Micra 16V ,Vauxhall Corsa Citreon Saxo 1.1i
Default Saxo overheating

saxo seams to be over heating fan keeps kicking in and water is boiling out after about 20 mins of driving took thermostat at checked that and thats fine i left it out today took it for another spin and its still overheating i am having the water pump changed tomorrow does anyone know if there would be anything else i can check ?
SxO13 is offline   Reply With Quote
Old 20th July 2010, 14:43   #2
nicole_
Saxperience Post Whore
Central Counties Region MemberNorth East Region Member
 
nicole_'s Avatar
 
Join Date: Jul 2009
Location: Newcastle
Posts: 6,694
Car(s): VTS & EK9
iTrader Score: 1 (100%)
Default

my overheating was HG
nicole_ is offline   Reply With Quote
Old 20th July 2010, 14:48   #3
bluenotesmiley
Established Member
South East Region Member
 
bluenotesmiley's Avatar
 
Join Date: May 2008
Location: Thanet, Kent
Posts: 1,529
Car(s): White MkII VTS Black MkII VTS
iTrader Score: 4 (100%)
Default

Is the coolant mixture correct? Also there may be an air blockage in the system; is it bled correctly?
bluenotesmiley is offline   Reply With Quote
Old 20th July 2010, 14:50   #4
SxO13
Regular Poster
South East Region Member
 
Join Date: Jan 2010
Location: west sussex
Posts: 338
Car(s): Nissan Micra 16V ,Vauxhall Corsa Citreon Saxo 1.1i
Default

what is HG
SxO13 is offline   Reply With Quote
Old 20th July 2010, 14:55   #5
nicole_
Saxperience Post Whore
Central Counties Region MemberNorth East Region Member
 
nicole_'s Avatar
 
Join Date: Jul 2009
Location: Newcastle
Posts: 6,694
Car(s): VTS & EK9
iTrader Score: 1 (100%)
Default

headgasket,
we tried 3 different rads as thought they may be leaking as it was loosing water, tried different fans, put a different stat on, etc
i had white smoke and was overfueling badly, other people say to look for gunk in the oil cap but i didnt have any of that,
nicole_ is offline   Reply With Quote
Old 20th July 2010, 22:23   #6
ryansaxo2010
Infrequent Poster
South Wales Region Member
 
ryansaxo2010's Avatar
 
Join Date: Jan 2010
Location: chepstow
Posts: 138
Car(s): saxo furio, vts conversion with cat cams and a tur
Default

check for all air locks in the system could be because its not bled through properly.... as for ur headgasket it depends where it goes as to where ull get the mayonaise gunk... oil ways or water ways .. check the end of ur dipstick for gunk.... it sounds like u may have stuffed ur hg and if its a highmilage unit and uve ragged it ull do what my mate dun to his rallye and crack the head .. but start simple first.
ryansaxo2010 is offline   Reply With Quote
Old 23rd July 2010, 11:16   #7
SxO13
Regular Poster
South East Region Member
 
Join Date: Jan 2010
Location: west sussex
Posts: 338
Car(s): Nissan Micra 16V ,Vauxhall Corsa Citreon Saxo 1.1i
Default

ok guys i thought id up date you on how the situation went i took it down to my local garge and this was the out come .. they took bits and boobs off to get to the water pump took the water pump out and fully checked that and cam to the conclustion it was good as new ! so then the guy said he thought the only other thing it could be was the rad. so he took the hoes off and checked for blockages or any leaks he bled the rad. twice and still couldent find what was the problem then after a few mins of headscratching he put the water pump back in and all the pipes and we later found out that it was just the cap onto of the rad as the system is ment to be presurerised and the seal in the cap had gone so therefore there was no pressure !!!! this was a complete piss take as i had to pay for the labour of the work he had done and then had to pay 5.55 for a cap !! LOL so if anyone was this little whining noise when you change gear etc please check the cap !!!!
SxO13 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:44.