Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 9th January 2017, 15:31   #1
Duckett25
Newbie
 
Join Date: Jan 2017
Posts: 4
Car(s): Saxo VTR
Default Wiring problem

Hi guys,

I was having trouble with the radio a while back and while messing about with it it seems I have somehow disconnected this bit, now I cannot remember where it came from but it is attached the the back of the internal fuse box so it must be fairly local to there, but I cannot see anything that it is supposed to attach to. Any ideas where it is supposed to go as I currently have no radio, or interior lights.

Everything seems to be plugged in behind radio and fuse box so I am stumped any help much appreciated!!!





Duckett25 is offline   Reply With Quote
Old 9th January 2017, 18:54   #2
marrygold
Regular Poster
 
Join Date: Aug 2010
Posts: 303
Default obd connection

it slides into a metal bracket in front of the fuses .
passenger side under glove box
marrygold is offline   Reply With Quote
Old 10th January 2017, 13:34   #3
bender
L-plater
 
bender's Avatar
 
Join Date: Sep 2015
Location: Weston Super Mare
Posts: 49
Car(s): 1998 MK1 Saxo 1.6 VTR 1995 Golf GTI 2.0
Default

It doesn't connect to anything. It's the diagnostic connector and just sits by the fuse box. Check the radio fuse
bender is offline   Reply With Quote
Old 11th January 2017, 15:58   #4
Duckett25
Newbie
 
Join Date: Jan 2017
Posts: 4
Car(s): Saxo VTR
Default

I have and the fuse seems to be ok. Tried a few different radios and none seem to be getting power. Any ideas what else could be causing it? Thanks
Duckett25 is offline   Reply With Quote
Old 20th April 2017, 22:56   #5
bender
L-plater
 
bender's Avatar
 
Join Date: Sep 2015
Location: Weston Super Mare
Posts: 49
Car(s): 1998 MK1 Saxo 1.6 VTR 1995 Golf GTI 2.0
Default

The radio needs two power sources and an earth to turn on. A constant 12v live, an ignition switched 12v live and thee earth. If you have an aftermarket radio there should be red and yellow wires connecting thee radio to the Car wiring. Try swapping these over, red to yellow and vice versa.

Sent from my KFFOWI using Tapatalk
bender is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 16:41.