Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 24th March 2019, 16:07   #1
Bodeka
Newbie
 
Join Date: Jul 2017
Posts: 27
Default Boot won't open

Hi, quite simple really, last night it opened, today it does not.

I can turn the key in the boot lock and unlock it. But I can not press it in fully, it sorta stops halfway. It won't push fully down, it feels like there's a pressure build up preventing this. When I lock the boot, I can push the opening button fully in as usual.

Any ideas?
Bodeka is offline   Reply With Quote
Old 24th March 2019, 16:23   #2
aldred309uk
Frequent Poster
 
aldred309uk's Avatar
 
Join Date: Feb 2014
Location: Blackburn, Lancashire
Posts: 576
Car(s): 2002 Citroen Saxo desire 2001 Volvo V40 1.9D
Default

For a period of time I had to have the boot locked, insert the key, push in the button and then turn the key with the button depressed. Was my only way in. I then disassembled the boot locking mechanism and lubed it all up.
aldred309uk is offline   Reply With Quote
Old 15th April 2019, 15:25   #3
Bodeka
Newbie
 
Join Date: Jul 2017
Posts: 27
Default

Quote:
Originally Posted by aldred309uk View Post
For a period of time I had to have the boot locked, insert the key, push in the button and then turn the key with the button depressed. Was my only way in. I then disassembled the boot locking mechanism and lubed it all up.
Cheers mate, but I tried that and it still didn't work. It also doesn't help that my drivers door also won't open, so if the passenger goes i'm not doing good haha.

Anyone got any ideas?
Bodeka is offline   Reply With Quote
Old 15th April 2019, 17:45   #4
MartinObviously
Saxperience Forum Bum
Track / Motorsport PrepScotland Region Member
 
MartinObviously's Avatar
 
Join Date: Dec 2012
Location: Perth
Posts: 3,307
Car(s): Peugeot 106 1.5D Peugeot 106 GTI '78 XJ-S
Default

Remove the trim from inside the boot and you'll see any problems.

Sounds like a bit of plastic may be broken off of the latch.
__________________
The rain kept a trollin'
MartinObviously is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 00:10.