Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 14th January 2007, 15:41   #1
piperX
Regular Poster
 
piperX's Avatar
 
Join Date: Apr 2006
Location: United Kingdom
Posts: 435
Exclamation power steering fault

i got a problemo with my power steering, had a look on the search but not to much info on there.

right then, a week ago my power steering (P-S) started making a wierd hissing kinda noise, when i turned the wheel, the noise you get when you put the car on full lock and hold it there. then i turned engine off and on and the P-S had cut out, then it came back on. did this a few times.

then finally yesterday i was driving it and it totally cut out. so i drove straight to my mechanics house and left it there for him to look at over the weekend. only to phone him up today and he said it was working fine again....... flippin car.

one thing i noticed though, the P-S fluid was more than MAX in the tank. any ideas??? ive never checked it before, could there be an air lock etc???

cheers for any help guys!!! REP GIVEN
piperX is offline   Reply With Quote
Old 14th January 2007, 21:06   #2
piperX
Regular Poster
 
piperX's Avatar
 
Join Date: Apr 2006
Location: United Kingdom
Posts: 435
Default

surely someone can give us some help, you guys are experts remember!!!!!
piperX is offline   Reply With Quote
Old 14th January 2007, 21:09   #3
hazyvtr
Infrequent Poster
 
hazyvtr's Avatar
 
Join Date: Jan 2007
Location: south wales
Posts: 108
Car(s): saxo vtr
Default

pumps gone or arelay
hazyvtr is offline   Reply With Quote
Old 14th January 2007, 21:33   #4
SAM33R
Established Member
 
SAM33R's Avatar
 
Join Date: Nov 2006
Posts: 2,134
Car(s): saxo vts 2003 *Dads*Änzo 15th APR
iTrader Score: 1 (100%)
Default

hello mate,

common fault them electro-hydraulic power steering pump

had mine done recently

basically when a pump cuts on and off, its usually a sign that the pump is on it way out

best to get it replaced mate as thats how mine packed up, it started working when it felt like and then fried up lol

your best bet is to get one from the breakers yard, around £40 from a late saxo model

hope this helps

sam
SAM33R is offline   Reply With Quote
Old 14th January 2007, 22:19   #5
Dan
Saxperience Hardcore!
North East Region Member
 
Dan's Avatar
 
Join Date: Dec 2003
Location: Middlesbrough United Kingdom (England)
Posts: 23,671
Car(s): Company car
iTrader Score: 1 (100%)
Default

Sounds like the pumps gone. Get one from a scrappy.
__________________
Old Skool Sax-p
Dan is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:32.