Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 3rd February 2023, 10:08   #1
pyxq
Newbie
 
Join Date: Feb 2023
Location: Finland
Posts: 25
pyxq is on a distinguished road
Default airbag light

Hello I have a 1998 saxo vtr/vts 1.4 8valve
The problem is that I have the finnish MOT incoming soon and the airbag light does not turn off. When I start the car it flashes for some while and then it just stays on, I've read the fault codes with autocom delphi and it said something along the lines of seatbelt circuit interrupted (sorry for the rough translation it was not worded properly even in finnish)
Well after doing some digging around this forum I found out that the connector under the seats might be the problem, no problem cut the connector out and soldered the wires together. Still the same problem, okay more digging around
and I found talk about using resistors to "trick" the airbag ecu. I bought some 2.2Ω resistors plugged them in and surprise surprise the light is still on.
I tried resetting the codes with the autocom.

The code:C3A1 seatbelt circuit interrupted
and a blank code without any numbers or text.

I'm open to any "illegal" "stupid" ideas. It's not likely that the survival % is going to be high in a saxo anyways only thing is that the airbag light must come on and turn off some time after the car is started
pyxq is offline   Reply With Quote
Old 3rd February 2023, 10:56   #2
Manu
Saxperience Addict
 
Manu's Avatar
 
Join Date: Dec 2009
Posts: 11,709
Car(s): A4 SE/A6 Le Mans
Manu is a glorious beacon of lightManu is a glorious beacon of lightManu is a glorious beacon of lightManu is a glorious beacon of lightManu is a glorious beacon of light
Default

Classic, I had it some time ago. Check the yellow wire itself, it's most likely broken inside the sleeve and you can't see it.

Worst case scenario you bypass the seatbelt, but in case of an accident you won't get a working pre-tensioner.


https://www.youtube.com/watch?v=vaoNGN4cGTY
Manu is offline   Reply With Quote
Old 3rd February 2023, 17:08   #3
pyxq
Newbie
 
Join Date: Feb 2023
Location: Finland
Posts: 25
pyxq is on a distinguished road
Default

Yeah I installed some resistors really close to the airbag ecu still the problem persists, even the same with the airbag itself. Well I thought I'll steal the light from the cat light next to the airbag with some jumpers, well worked in for a few hours. and now my tacho, speedo and fuel don't work unless im holding the key in start position. And i just broke my batt negative terminal, I'll have to get a new terminal. MOT due in 13 days, as long as the light lights up and turns off a few seconds after starting I'm good, otherwise a brillian car and low mileage (only 119000km)
pyxq is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 13:06.