Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Engine/Performance

Saxo Engine/Performance If you're interested in tuning Saxo engines, or if you need to know something which is engine related... this is the place for you.

Reply
 
Thread Tools Display Modes
Old 20th June 2013, 15:02   #1
Moorzy1990
L-plater
 
Join Date: Jun 2009
Location: Nottingham
Posts: 37
Unhappy VTS Cutting out ?

Hi people need some advice....

My 2000 vts has been a bitch recently with regards to idling. (big shock)
What happens is when you full throttle and get the revs up all is well, but when you come to a set of traffic lights the rev dips then it cuts out.

But on the over hand if you drive like a nun nothing happens and if you rev half way up the rev counter it will dipp but still come back to about 900rpm?

Iv changed MAP sensor and Idle control valve. Could a faulty throttle sensor cause these issues.

Thanks for any answers in advanced...
Moorzy1990 is offline   Reply With Quote
Old 25th June 2013, 12:15   #2
Moorzy1990
L-plater
 
Join Date: Jun 2009
Location: Nottingham
Posts: 37
Default

??????????
Moorzy1990 is offline   Reply With Quote
Old 25th June 2013, 12:45   #3
Hazmanscoop
Established Member
North East Region Member
 
Hazmanscoop's Avatar
 
Join Date: Oct 2008
Location: Witney
Posts: 2,481
Car(s): Black VTS
iTrader Score: 1 (100%)
Default

Ive heard its the crank sensor thats bust.

mine does this sometimes and i've been told its that.
__________________


Quote:
Originally Posted by Gabbastard View Post
I managed to make it outside once but i didnt like it - i couldnt work out how to click on people and trees and stuff
Hazmanscoop is offline   Reply With Quote
Old 1st July 2013, 16:29   #4
Moorzy1990
L-plater
 
Join Date: Jun 2009
Location: Nottingham
Posts: 37
Default

Thanks for the reply

will deffo try the crank sensor, had the car dyno'd and they say the coil I have in is prone to faults (sagem coil) and it cann spike the ECU so think ill give both ago.

Fingers crossed...
Moorzy1990 is offline   Reply With Quote
Old 1st July 2013, 16:31   #5
Cam
Saxperience Post Whore
South East Region Member
 
Cam's Avatar
 
Join Date: Nov 2010
Location: Kent
Posts: 8,444
Car(s): Gen 7 Celica 190.
iTrader Score: 8 (100%)
Default

It wont be the crank sensor.

Have you tryed to read any error codes from it?
Cam is offline   Reply With Quote
Old 1st July 2013, 16:40   #6
Moorzy1990
L-plater
 
Join Date: Jun 2009
Location: Nottingham
Posts: 37
Default

Yea came back with MAF sensor fault which I'm guessing is the MAP sensor or the Idle control valve, I have changed the Map sensor but its only got cheapo control valve so....

also it seems to run on three cylinders at times, annoyed because I don't want to have to sell
Moorzy1990 is offline   Reply With Quote
Old 1st July 2013, 17:08   #7
Moorzy1990
L-plater
 
Join Date: Jun 2009
Location: Nottingham
Posts: 37
Default

Just to add, if it cuts out I can turn it off then wait a few seconds, start it up again and it will be fine.
Moorzy1990 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 21:01.