Mobile Devices: Lite Theme CitroŽn: CitroŽn Trader | Saxo Trader | C2 Trader Peugeot: Peugeot Trader | 106 Trader Enthusiast: Saxperience


Go Back   Saxperience - Citroen Saxo Forum > Citroen Saxo Related Forums > Saxo Problems & Queries

Saxo Problems & Queries If you're having problems with your Saxo and you're after a bit of advice, check this forum out...

Reply
 
Thread Tools Display Modes
Old 26th September 2022, 21:05   #1
VeiRoN
Established Member
South East Region Member
 
VeiRoN's Avatar
 
Join Date: Aug 2012
Posts: 1,991
Car(s): SaxÚ VTS 16v
iTrader Score: 8 (100%)
VeiRoN is on a distinguished road
Default Lamda fault code Single Plug conversion

Hi, I've done a single plug Saxo VTS conversion using the guide on here to splice the multi plug in the engine bay correctly from the VTS 3 plug,the only issue I have is a fault code for the Lambda P0157 intermittent, only comes on after the car is warmed up,the engine light does not come on.

As per guide I spliced the Lambda together with a ignition wire to get its positive from,I do have the correct black Lambda sensor for the single plug ECU and I do have voltage on the connector,I have around 800mv with the car running and I've 12v on the Lambda pins 1,2 and 3 and 8 volts on pin 4 with the ignition on,why am I getting the fault code? Not sure what else to check to be honest.

Car is not standard and it's currently running with the stock single plug ECU on a base map,I understand that the fuel map is not set up accurately but I wouldn't of thought I would get a fault code for the O2 sensor for this?

Also worth to note, I've got no reading on the cluster for the coolant temperature,I do have correct reading of the sensor using the odb, would the gauge not working on the clusters affect the 02 sensor? I thought it only cared about the ECU sensor, thank you.

Also,I was just thinking,is it not for the second O2 sensor the P0157 code? Looks like it is from what I can find.


Last edited by VeiRoN; 2nd October 2022 at 19:26.
VeiRoN is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 14:57.